What’s Vulnerable › Vulnerabilities
CVE-2023-3154: NextGEN Gallery < 3.39 - Admin+ PHAR Deserialization
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-16 · updated 2026-06-17
Description
The WordPress Gallery Plugin WordPress plugin before 3.39 is vulnerable to PHAR Deserialization due to a lack of input parameter validation in the `gallery_edit` function, allowing an attacker to access arbitrary resources on the server.
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 3.39 — fixed in 3.39
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 3.39. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ed099489-1db4-4b42-9f72-77de39c9e01e
- https://wpscan.com/vulnerability/ed099489-1db4-4b42-9f72-77de39c9e01e
Get alerted when CVE-2023-3154 or the next vulnerability affects your stack