What’s Vulnerable › Vulnerabilities
CVE-2023-3155: NextGEN Gallery < 3.39 - Admin+ Arbitrary File Read and Delete
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-552
Description
The WordPress Gallery Plugin WordPress plugin before 3.39 is vulnerable to Arbitrary File Read and Delete due to a lack of input parameter validation in the `gallery_edit` function, allowing an attacker to access arbitrary resources on the server.
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 3.39 — fixed in 3.39
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 3.39. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5c8473f4-4b52-430b-9140-b81b0a0901da
- https://wpscan.com/vulnerability/5c8473f4-4b52-430b-9140-b81b0a0901da
Get alerted when CVE-2023-3155 or the next vulnerability affects your stack