What’s Vulnerable › Vulnerabilities
CVE-2023-40196: WordPress ImageRecycle pdf & image compression Plugin <= 3.1.11 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in ImageRecycle ImageRecycle pdf & image compression plugin <= 3.1.11 versions.
Affected products
- ImageRecycle pdf & image compression: before 3.1.12 — fixed in 3.1.12
How to fix
Upgrade to a fixed version: ImageRecycle pdf & image compression 3.1.12. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/imagerecycle-pdf-image-compression/wordpress-imagerecycle-pdf-image-compression-plugin-3-1-11-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/imagerecycle-pdf-image-compression/wordpress-imagerecycle-pdf-image-compression-plugin-3-1-11-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-40196 or the next vulnerability affects your stack