What’s Vulnerable › Products
ImageRecycle pdf & image compression vulnerabilities
15 known vulnerabilities, 0 confirmed exploited in the wild (CISA KEV), 1 published in the last 12 months.
Check whether your ImageRecycle pdf & image compression version is affected
Latest ImageRecycle pdf & image compression vulnerabilities
- CVE-2024-54266 — WordPress ImageRecycle pdf & image compression plugin <= 3.1.16 - Reflected Cross Site Scripting (XSS) vulnerability (CVSS 6.1)
- CVE-2024-8120 — ImageRecycle pdf & image compression <= 3.1.14 - Cross-Site Request in Several AJAX Actions (CVSS 4.3)
- CVE-2024-6631 — ImageRecycle pdf & image compression <= 3.1.14 - Missing Authorization in Several AJAX Actions (CVSS 4.3)
- CVE-2024-1339 — ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Plugin Data Removal in reinitialize (CVSS 4.3)
- CVE-2024-1338 — ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in stopOptimizeAll (CVSS 4.3)
- CVE-2024-1336 — ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in optimizeAllOn (CVSS 4.3)
- CVE-2024-1335 — ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in disableOptimization (CVSS 4.3)
- CVE-2024-1334 — ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in enableOptimization (CVSS 4.3)
- CVE-2024-1091 — ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Plugin Data Removal in reinitialize (CVSS 4.3)
- CVE-2024-1090 — ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Settings Update in stopOptimizeAll (CVSS 4.3)
- CVE-2024-1089 — ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Settings Update in optimizeAllOn (CVSS 4.3)
- CVE-2024-0984 — ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Settings Update in disableOptimization (CVSS 4.3)
- CVE-2024-0983 — ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Settings Update in enableOptimization (CVSS 4.3)
- CVE-2023-40196 — WordPress ImageRecycle pdf & image compression Plugin <= 3.1.11 is vulnerable to Cross Site Scripting (XSS) (CVSS 6.1)
- CVE-2023-30494 — WordPress ImageRecycle pdf & image compression Plugin <= 3.1.10 is vulnerable to Cross Site Scripting (XSS) (CVSS 6.1)