What’s Vulnerable › Vulnerabilities
CVE-2024-1336: ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in optimizeAllOn
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-352
Description
The ImageRecycle pdf & image compression plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.1.13. This is due to missing or incorrect nonce validation on the optimizeAllOn function. This makes it possible for unauthenticated attackers to modify image optimization settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- ImageRecycle pdf & image compression: before 3.1.14 — fixed in 3.1.14
How to fix
Upgrade to a fixed version: ImageRecycle pdf & image compression 3.1.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3031424/imagerecycle-pdf-image-compression
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ca4cf299-9dee-4ebf-83f3-4c3471bd9fb0?source=cve
- https://plugins.trac.wordpress.org/changeset/3031424/imagerecycle-pdf-image-compression
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ca4cf299-9dee-4ebf-83f3-4c3471bd9fb0?source=cve
Get alerted when CVE-2024-1336 or the next vulnerability affects your stack