What’s Vulnerable › Vulnerabilities
CVE-2024-1091: ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Plugin Data Removal in reinitialize
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-862
Description
The ImageRecycle pdf & image compression plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the reinitialize function in all versions up to, and including, 3.1.13. This makes it possible for authenticated attackers, with subscriber-level access and above, to remove all plugin data.
Affected products
- ImageRecycle pdf & image compression: before 3.1.14 — fixed in 3.1.14
How to fix
Upgrade to a fixed version: ImageRecycle pdf & image compression 3.1.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3031424/imagerecycle-pdf-image-compression
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3cb8b08c-a028-48bd-acad-c00313fe06b8?source=cve
- https://plugins.trac.wordpress.org/changeset/3031424/imagerecycle-pdf-image-compression
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3cb8b08c-a028-48bd-acad-c00313fe06b8?source=cve
Get alerted when CVE-2024-1091 or the next vulnerability affects your stack