What’s Vulnerable › Vulnerabilities
CVE-2024-6631: ImageRecycle pdf & image compression <= 3.1.14 - Missing Authorization in Several AJAX Actions
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-24 · updated 2026-06-17
- Weakness: CWE-862
Description
The ImageRecycle pdf & image compression plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several AJAX actions in all versions up to, and including, 3.1.14. This makes it possible for authenticated attackers, with Subscriber-level access and above, to perform unauthorized actions, such as updating plugin settings.
Affected products
- ImageRecycle pdf & image compression: before 3.1.15 — fixed in 3.1.15
How to fix
Upgrade to a fixed version: ImageRecycle pdf & image compression 3.1.15. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3119956/imagerecycle-pdf-image-compression/tags/3.1.15/class/class-image-otimizer.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f330bf36-0a39-40d6-a075-c87fdb9dc2da?source=cve
Get alerted when CVE-2024-6631 or the next vulnerability affects your stack