What’s Vulnerable › Vulnerabilities
CVE-2024-8120: ImageRecycle pdf & image compression <= 3.1.14 - Cross-Site Request in Several AJAX Actions
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-24 · updated 2026-06-17
- Weakness: CWE-352
Description
The ImageRecycle pdf & image compression plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.1.14. This is due to missing or incorrect nonce validation on several functions in the class/class-image-otimizer.php file. This makes it possible for unauthenticated attackers to update plugin settings along with performing other actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- ImageRecycle pdf & image compression: before 3.1.15 — fixed in 3.1.15
How to fix
Upgrade to a fixed version: ImageRecycle pdf & image compression 3.1.15. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3119956/imagerecycle-pdf-image-compression/tags/3.1.15/class/class-image-otimizer.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a06bba7f-0259-4b87-b3fe-6ad8318fda7d?source=cve
Get alerted when CVE-2024-8120 or the next vulnerability affects your stack