What’s Vulnerable › Vulnerabilities
CVE-2023-5604: Asgaros Forum < 2.7.1 - Unauthenticated Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-94
Description
The Asgaros Forum WordPress plugin before 2.7.1 allows forum administrators, who may not be WordPress (super-)administrators, to set insecure configuration that allows unauthenticated users to upload dangerous files (e.g. .php, .phtml), potentially leading to remote code execution.
Affected products
- Asgaros Forum: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: Asgaros Forum 2.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4ce69d71-87bf-4d95-90f2-63d558c78b69
- https://wpscan.com/vulnerability/4ce69d71-87bf-4d95-90f2-63d558c78b69
Get alerted when CVE-2023-5604 or the next vulnerability affects your stack