What’s Vulnerable › Vulnerabilities
CVE-2023-6292: Ecwid Ecommerce Shopping Cart < 6.12.5 - Arbitrary Plugin Settings Change via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-352
Description
The Ecwid Ecommerce Shopping Cart WordPress plugin before 6.12.5 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.
Affected products
- Ecwid Ecommerce Shopping Cart: before 6.12.5 — fixed in 6.12.5
How to fix
Upgrade to a fixed version: Ecwid Ecommerce Shopping Cart 6.12.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d4cf799e-2571-4b96-a303-78dcafbfcf40/
- https://wpscan.com/vulnerability/d4cf799e-2571-4b96-a303-78dcafbfcf40/
Get alerted when CVE-2023-6292 or the next vulnerability affects your stack