What’s Vulnerable › Vulnerabilities
CVE-2023-6585: JobSearch WP Job Board < 2.3.4 - Arbitrary File Upload to RCE
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-27 · updated 2026-06-17
Description
The WP JobSearch WordPress plugin before 2.3.4 does not validate files to be uploaded, which could allow unauthenticated attackers to upload arbitrary files such as PHP on the server
Affected products
- eyecix JobSearch: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: eyecix JobSearch 2.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/757412f4-e4f8-4007-8e3b-639a72b33180/
- https://wpscan.com/vulnerability/757412f4-e4f8-4007-8e3b-639a72b33180/
Get alerted when CVE-2023-6585 or the next vulnerability affects your stack