What’s Vulnerable › Vulnerabilities
CVE-2024-10117: WP Crowdfunding <= 2.1.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpcf_donate Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Crowdfunding plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wpcf_donate shortcode in all versions up to, and including, 2.1.11 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- themeum WP Crowdfunding: before 2.1.12 — fixed in 2.1.12
How to fix
Upgrade to a fixed version: themeum WP Crowdfunding 2.1.12. Check the vendor advisory for mitigations.
References
- https://docs.themeum.com/wp-crowdfunding/
- https://plugins.trac.wordpress.org/changeset/3174230/
- https://plugins.trac.wordpress.org/changeset/3174230/#file19
- https://wordpress.org/plugins/wp-crowdfunding/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7813dfdc-06e0-4fa9-aabe-b5b9772368c2?source=cve
Get alerted when CVE-2024-10117 or the next vulnerability affects your stack