What’s Vulnerable › Vulnerabilities
CVE-2024-10480: 3DPrint Lite < 2.1 - Settings Update via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-06 · updated 2026-06-17
- Weakness: CWE-352
Description
The 3DPrint Lite WordPress plugin before 2.1 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.
Affected products
- fuzzoid 3DPrint Lite: before 2.1 — fixed in 2.1
How to fix
Upgrade to a fixed version: fuzzoid 3DPrint Lite 2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10480 or the next vulnerability affects your stack