What’s Vulnerable › Vulnerabilities
CVE-2024-10711: WooCommerce Report <= 1.5.1 - Cross-Site Request Forgery to Arbitrary Options Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-352
Description
The WooCommerce Report plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.5.1. This is due to missing or incorrect nonce validation on the settings update functionality. This makes it possible for unauthenticated attackers to update arbitrary options that can be leveraged for privilege escalation via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- ithemelandco REPORTiT – Advanced Reporting for WooCommerce: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: ithemelandco REPORTiT – Advanced Reporting for WooCommerce 1.5.2. Check the vendor advisory for mitigations.
References
- https://ithemelandco.com/docs/woocommerce-report/
- https://plugins.trac.wordpress.org/browser/ithemelandco-woo-report/trunk/class/setting_report.php#L1174
- https://plugins.trac.wordpress.org/changeset/3181117/
- https://wordpress.org/plugins/ithemelandco-woo-report/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d1d21339-3a86-4bee-be86-2d2ab9190b26?source=cve
Get alerted when CVE-2024-10711 or the next vulnerability affects your stack