What’s Vulnerable › Vulnerabilities
CVE-2024-10892: Cost Calculator Builder < 3.2.43 - Settings update via CSRF
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-18 · updated 2026-06-17
- Weakness: CWE-352
Description
The Cost Calculator Builder WordPress plugin before 3.2.43 does not have CSRF checks in some AJAX actions, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks.
Affected products
- stylemix Cost Calculator Builder: before 3.2.43 — fixed in 3.2.43
How to fix
Upgrade to a fixed version: stylemix Cost Calculator Builder 3.2.43. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10892 or the next vulnerability affects your stack