What’s Vulnerable › Vulnerabilities
CVE-2024-11910: WP Crowdfunding <= 2.1.15 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Crowdfunding plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the wp-crowdfunding/search block in all versions up to, and including, 2.1.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- themeum WP Crowdfunding: before 2.1.13 — fixed in 2.1.13
How to fix
Upgrade to a fixed version: themeum WP Crowdfunding 2.1.13. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-crowdfunding/trunk/includes/blocks/Search.php#L70
- https://plugins.trac.wordpress.org/changeset/3206336/wp-crowdfunding/trunk/includes/blocks/Search.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3298270%40wp-crowdfunding&new=3298270%40wp-crowdfunding&sfp_email=&sfph_mail=#file7
- https://wordpress.org/plugins/wp-crowdfunding/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b1541aaf-9f35-44b5-a985-1b8d33228f0a?source=cve
Get alerted when CVE-2024-11910 or the next vulnerability affects your stack