What’s Vulnerable › Vulnerabilities
CVE-2024-11917: JobSearch WP Job Board <= 2.9.2 - Authentication Bypass via Social Logins
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-25 · updated 2026-06-17
- Weakness: CWE-287
Description
The JobSearch WP Job Board plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 2.9.2. This is due to improper configurations in the 'jobsearch_xing_response_data_callback', 'set_access_tokes', and 'google_callback' functions. This makes it possible for unauthenticated attackers to log in as the first connected Xing user, or any connected Xing user if the Xing id is known. It is also possible for unauthenticated attackers to log in as the first connected Google user if the user has logged in, without subsequently logging out, in thirty days. The vulnerability was partially patched in version 2.8.4.
Affected products
- eyecix JobSearch: through 2.9.2
References
- https://codecanyon.net/item/jobsearch-wp-job-board-wordpress-plugin/21066856
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6de8a608-8715-4f9c-9f2f-df60dd1cc579?source=cve
Get alerted when CVE-2024-11917 or the next vulnerability affects your stack