What’s Vulnerable › Vulnerabilities
CVE-2024-12213: WP Job Board Pro < 1.2.85 - Unauthenticated Privilege Escalation via process_register
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-266
Description
The WP Job Board Pro plugin for WordPress is vulnerable to privilege escalation in all versions up to 2.3.16. This is due to the plugin allowing a user to supply the 'role' field when registering. This makes it possible for unauthenticated attackers to register as an administrator on vulnerable sites. Please note that this may have been patched sooner, however, the oldest available version for us to confirm this is patched in was 1.2.85.
Affected products
- Superio: through 1.2.76
References
- https://themeforest.net/item/superio-job-board-wordpress-theme/32180231
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7cdfce88-b6c2-4820-9d6f-446f61b9b596?source=cve
Get alerted when CVE-2024-12213 or the next vulnerability affects your stack