What’s Vulnerable › Vulnerabilities
CVE-2024-22284: WordPress Asgaros Forum Plugin <= 2.7.2 is vulnerable to PHP Object Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-24 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in Thomas Belser Asgaros Forum.This issue affects Asgaros Forum: from n/a through 2.7.2.
Affected products
- Asgaros Forum: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Asgaros Forum 2.8.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/asgaros-forum/wordpress-asgaros-forum-plugin-2-7-2-php-object-injection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/asgaros-forum/wordpress-asgaros-forum-plugin-2-7-2-php-object-injection-vulnerability?_s_id=cve
Get alerted when CVE-2024-22284 or the next vulnerability affects your stack