What’s Vulnerable › Vulnerabilities
CVE-2024-25591: WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-17 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Benjamin Rojas WP Editor.This issue affects WP Editor: from n/a through 1.2.7.
Affected products
- benjaminprojas WP Editor: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: benjaminprojas WP Editor 1.2.8. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-editor/wordpress-wp-editor-plugin-1-2-7-sensitive-data-exposure-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-editor/wordpress-wp-editor-plugin-1-2-7-sensitive-data-exposure-vulnerability?_s_id=cve
Get alerted when CVE-2024-25591 or the next vulnerability affects your stack