What’s Vulnerable › Vulnerabilities
CVE-2024-27996: WordPress Survey Maker plugin <= 4.0.5 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Survey Maker team Survey Maker allows Stored XSS.This issue affects Survey Maker: from n/a through 4.0.5.
Affected products
- Ays Pro Survey Maker: before 4.0.6 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: Ays Pro Survey Maker 4.0.6. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/survey-maker/wordpress-survey-maker-plugin-4-0-5-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/survey-maker/wordpress-survey-maker-plugin-4-0-5-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-27996 or the next vulnerability affects your stack