What’s Vulnerable › Vulnerabilities
CVE-2024-37922: WordPress Premium Addons for Elementor plugin <= 4.10.34 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Leap13 Premium Addons for Elementor premium-addons-for-elementor.This issue affects Premium Addons for Elementor: from n/a through <= 4.10.34.
Affected products
- leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets: before 4.10.35 — fixed in 4.10.35
How to fix
Upgrade to a fixed version: leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets 4.10.35. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/premium-addons-for-elementor/vulnerability/wordpress-premium-addons-for-elementor-plugin-4-10-34-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/premium-addons-for-elementor/wordpress-premium-addons-for-elementor-plugin-4-10-34-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-37922 or the next vulnerability affects your stack