What’s Vulnerable › Vulnerabilities

CVE-2024-3895: WP Datepicker <= 2.1.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update

Description

The WP Datepicker plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpdp_add_new_datepicker_ajax() function in all versions up to, and including, 2.1.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary options that can be used for privilege escalation. This was partially patched in 2.0.9 and 2.1.0, and fully patched in 2.1.1.

Affected products

How to fix

Upgrade to a fixed version: Fahad Mahmood WP Datepicker 2.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-3895 or the next vulnerability affects your stack