What’s Vulnerable › Vulnerabilities
CVE-2024-39627: WordPress Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin <= 3.59.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Imagely NextGEN Gallery allows Stored XSS.This issue affects NextGEN Gallery: from n/a through 3.59.3.
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 3.59.4 — fixed in 3.59.4
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 3.59.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39627 or the next vulnerability affects your stack