What’s Vulnerable › Vulnerabilities
CVE-2024-4061: Survey Maker < 4.2.9 - Admin+ Stored XSS via Plugin Settings
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Survey Maker WordPress plugin before 4.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Ays Pro Survey Maker: before 4.2.9 — fixed in 4.2.9
How to fix
Upgrade to a fixed version: Ays Pro Survey Maker 4.2.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/175a9f3a-1f8d-44d1-8a12-e037251b025d/
- https://wpscan.com/vulnerability/175a9f3a-1f8d-44d1-8a12-e037251b025d/
Get alerted when CVE-2024-4061 or the next vulnerability affects your stack