What’s Vulnerable › Vulnerabilities

CVE-2024-4376: Premium Addons for Elementor <= 4.10.31 - Authenticated (Contributor+) Stored Cross-Site Scripting via Fancy Text Widget

Description

The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Fancy Text widget in all versions up to, and including, 4.10.31 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. While 4.10.32 is patched, it is recommended to update to 4.10.33 because 4.10.32 caused a fatal error.

Affected products

How to fix

Upgrade to a fixed version: leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets 4.10.32. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4376 or the next vulnerability affects your stack