What’s Vulnerable › Vulnerabilities
CVE-2024-44042: WordPress WP Datepicker plugin <= 2.1.1 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Fahad Mahmood WP Datepicker wp-datepicker allows Stored XSS.This issue affects WP Datepicker: from n/a through <= 2.1.1.
Affected products
- Fahad Mahmood WP Datepicker: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Fahad Mahmood WP Datepicker 2.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-44042 or the next vulnerability affects your stack