What’s Vulnerable › Vulnerabilities
CVE-2024-4858: Testimonial Carousel For Elementor <= 10.2.0 - Missing Authorization to Limited Setting Update
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-25 · updated 2026-06-17
- Weakness: CWE-862
Description
The Testimonial Carousel For Elementor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'save_testimonials_option_callback' function in versions up to, and including, 10.2.0. This makes it possible for unauthenticated attackers to update the OpenAI API key, disabling the feature.
Affected products
- uapp Testimonial Carousel For Elementor: before 10.2.1 — fixed in 10.2.1
How to fix
Upgrade to a fixed version: uapp Testimonial Carousel For Elementor 10.2.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/testimonials-carousel-elementor/trunk/class-testimonials-carousel-elementor.php#L126
- https://plugins.trac.wordpress.org/changeset/3092154/testimonials-carousel-elementor/trunk/class-testimonials-carousel-elementor.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1f589345-a081-4d27-ac4a-6edc44b96f91?source=cve
- https://plugins.trac.wordpress.org/browser/testimonials-carousel-elementor/trunk/class-testimonials-carousel-elementor.php#L126
- https://plugins.trac.wordpress.org/changeset/3092154/testimonials-carousel-elementor/trunk/class-testimonials-carousel-elementor.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1f589345-a081-4d27-ac4a-6edc44b96f91?source=cve
Get alerted when CVE-2024-4858 or the next vulnerability affects your stack