What’s Vulnerable › Vulnerabilities
CVE-2024-5442: NextGEN Gallery < 3.59.3 - Admin+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Photo Gallery, Sliders, Proofing and WordPress plugin before 3.59.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 3.59.3 — fixed in 3.59.3
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 3.59.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4f1fa417-f760-4132-95c2-a38d0b631263/
- https://wpscan.com/vulnerability/4f1fa417-f760-4132-95c2-a38d0b631263/
Get alerted when CVE-2024-5442 or the next vulnerability affects your stack