What’s Vulnerable › Vulnerabilities
CVE-2024-6012: Cost Calculator Builder <= 3.2.12 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Content Creation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-02 · updated 2026-06-17
- Weakness: CWE-862
Description
The Cost Calculator Builder plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'embed-create-page' and 'embed-insert-pages' functions in all versions up to, and including, 3.2.12. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create arbitrary posts and append arbitrary content to existing posts.
Affected products
- stylemix Cost Calculator Builder: before 3.2.13 — fixed in 3.2.13
How to fix
Upgrade to a fixed version: stylemix Cost Calculator Builder 3.2.13. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/cost-calculator-builder/trunk/frontend/dist/admin.js
- https://plugins.trac.wordpress.org/changeset/3108606/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fd7da039-f6b8-46b7-a43a-145e9f8844c3?source=cve
- https://plugins.trac.wordpress.org/browser/cost-calculator-builder/trunk/frontend/dist/admin.js
- https://plugins.trac.wordpress.org/changeset/3108606/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fd7da039-f6b8-46b7-a43a-145e9f8844c3?source=cve
Get alerted when CVE-2024-6012 or the next vulnerability affects your stack