What’s Vulnerable › Vulnerabilities
CVE-2024-6393: NextGEN Gallery < 3.59.5 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Photo Gallery, Sliders, Proofing and WordPress plugin before 3.59.5 does not sanitise and escape some of its Images settings, which could allow high privilege users such as Admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 3.59.5 — fixed in 3.59.5
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 3.59.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6393 or the next vulnerability affects your stack