What’s Vulnerable › Vulnerabilities
CVE-2024-6869: Falang multilanguage for WordPress <= 1.3.52 - Missing Authorization to Translation Update and Information Exposure
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-862
Description
The Falang multilanguage for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several functions in all versions up to, and including, 1.3.52. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update and delete translations and expose the administrator email address.
Affected products
- sbouey Falang multilanguage for WordPress: before 1.3.53 — fixed in 1.3.53
How to fix
Upgrade to a fixed version: sbouey Falang multilanguage for WordPress 1.3.53. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/falang/trunk/admin/class-falang-admin.php
- https://plugins.trac.wordpress.org/changeset/3131499/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cd4d67cd-5fb0-425d-8b22-c69ebb0ffa72?source=cve
Get alerted when CVE-2024-6869 or the next vulnerability affects your stack