What’s Vulnerable › Vulnerabilities
CVE-2024-7423: Stream <= 4.0.1 - Cross-Site Request Forgery to Arbitrary Options Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-352
Description
The Stream plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.0.1. This is due to missing or incorrect nonce validation on the network_options_action() function. This makes it possible for unauthenticated attackers to update arbitrary options that can lead to DoS or privilege escalation via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- XWP Stream: before 4.0.2 — fixed in 4.0.2
How to fix
Upgrade to a fixed version: XWP Stream 4.0.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/stream/tags/4.0.1/classes/class-network.php#L353
- https://plugins.trac.wordpress.org/changeset/3139815/stream/trunk/classes/class-network.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9d15e418-36bb-4f53-ac67-8f6122591dd2?source=cve
Get alerted when CVE-2024-7423 or the next vulnerability affects your stack