What’s Vulnerable › Vulnerabilities
CVE-2024-7888: Classified Listing – Classified ads & Business Directory Plugin <= 3.1.7 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-862
Description
The Classified Listing – Classified ads & Business Directory Plugin plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several functions like export_forms(), import_forms(), update_fb_options(), and many more in all versions up to, and including, 3.1.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to modify forms and various other settings.
Affected products
- RadiusTheme Classified Listing: before 3.1.8 — fixed in 3.1.8
How to fix
Upgrade to a fixed version: RadiusTheme Classified Listing 3.1.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/classified-listing/tags/3.1.6/app/Controllers/Ajax/FormBuilderAdminAjax.php
- https://plugins.trac.wordpress.org/changeset/3150743/classified-listing/trunk/app/Controllers/Ajax/FormBuilderAdminAjax.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/494d2e69-0759-419a-a603-e8870c157e49?source=cve
Get alerted when CVE-2024-7888 or the next vulnerability affects your stack