What’s Vulnerable › Vulnerabilities
CVE-2024-8379: Cost Calculator Builder < 3.2.29 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-30 · updated 2026-06-17
- Weakness: CWE-89
Description
The Cost Calculator Builder WordPress plugin before 3.2.29 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by users with a role as low as Admin.
Affected products
- stylemix Cost Calculator Builder: before 3.2.29 — fixed in 3.2.29
How to fix
Upgrade to a fixed version: stylemix Cost Calculator Builder 3.2.29. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8379 or the next vulnerability affects your stack