What’s Vulnerable › Vulnerabilities
CVE-2024-8614: WP JobSearch <= 2.6.7 - Authenticated (Subscriber+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-434
Description
The JobSearch WP Job Board plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the jobsearch_wp_handle_upload() function in all versions up to, and including, 2.6.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- eyecix JobSearch: before 2.6.8 — fixed in 2.6.8
How to fix
Upgrade to a fixed version: eyecix JobSearch 2.6.8. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/jobsearch-wp-job-board-wordpress-plugin/21066856
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7832f8fe-2b41-4cfb-a734-db4ec88d91a3?source=cve
Get alerted when CVE-2024-8614 or the next vulnerability affects your stack