What’s Vulnerable › Vulnerabilities
CVE-2024-8615: WP JobSearch <= 2.6.7 - Unauthenticated Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-434
Description
The JobSearch WP Job Board plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the jobsearch_location_load_excel_file_callback() function in all versions up to, and including, 2.6.7. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- eyecix JobSearch: before 2.6.8 — fixed in 2.6.8
How to fix
Upgrade to a fixed version: eyecix JobSearch 2.6.8. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/jobsearch-wp-job-board-wordpress-plugin/21066856
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dd718d44-4921-4deb-af5a-43e5f3926914?source=cve
Get alerted when CVE-2024-8615 or the next vulnerability affects your stack