What’s Vulnerable › Vulnerabilities
CVE-2025-0865: WP Media Category Management 2.0 - 2.3.3 - Cross-Site Request Forgery to Settings Update
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-19 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Media Category Management plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions 2.0 to 2.3.3. This is due to missing or incorrect nonce validation on the wp_mcm_handle_action_settings() function. This makes it possible for unauthenticated attackers to alter plugin settings, such as the taxonomy used for media, the base slug for media categories, and the default media category via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- DeBAAT WP Media Category Management: from 2.0.0 before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: DeBAAT WP Media Category Management 2.4.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-media-category-management/tags/2.3.3/include/admin/class-WP_MCM_Render_Settings.php
- https://plugins.trac.wordpress.org/browser/wp-media-category-management/trunk/include/admin/class-WP_MCM_Settings.php
- https://plugins.trac.wordpress.org/browser/wp-media-category-management/trunk/include/class-WP_MCM_Options.php
- https://plugins.trac.wordpress.org/changeset/3242626/wp-media-category-management/trunk/include/admin/class-WP_MCM_Settings.php
- https://wordpress.org/plugins/wp-media-category-management/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0d42ca2f-f061-4cd1-812b-46d42c440498?source=cve
Get alerted when CVE-2025-0865 or the next vulnerability affects your stack