What’s Vulnerable › Vulnerabilities
CVE-2025-1063: Classified Listing – Classified ads & Business Directory Plugin <= 4.0.4 - Unauthenticated Settings Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-25 · updated 2026-06-17
- Weakness: CWE-200
Description
The Classified Listing – Classified ads & Business Directory Plugin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.0.4 via the rtcl_taxonomy_settings_export function. This makes it possible for unauthenticated attackers to extract sensitive data including API keys and tokens.
Affected products
- RadiusTheme Classified Listing: before 4.0.5 — fixed in 4.0.5
How to fix
Upgrade to a fixed version: RadiusTheme Classified Listing 4.0.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3241883/classified-listing
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e701b771-59f2-4783-b0a1-bea4d6c3d245?source=cve
Get alerted when CVE-2025-1063 or the next vulnerability affects your stack