What’s Vulnerable › Vulnerabilities
CVE-2025-14163: Premium Addons for Elementor <= 4.11.53 - Cross-Site Request Forgery via 'insert_inner_template'
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-23 · updated 2026-10-19
- Weakness: CWE-352
Description
The Premium Addons for Elementor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.11.53. This is due to missing nonce validation in the 'insert_inner_template' function. This makes it possible for unauthenticated attackers to create arbitrary Elementor templates via a forged request granted they can trick a site administrator or other user with the edit_posts capability into performing an action such as clicking on a link.
Affected products
- leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets: before 4.11.54 — fixed in 4.11.54
How to fix
Upgrade to a fixed version: leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets 4.11.54. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/premium-addons-for-elementor/tags/4.11.53/includes/templates/classes/manager.php#L246
- https://plugins.trac.wordpress.org/browser/premium-addons-for-elementor/tags/4.11.53/includes/templates/classes/manager.php#L40
- https://plugins.trac.wordpress.org/changeset/3416254/
- https://research.cleantalk.org/cve-2025-14163/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/77b57f2a-0b46-4b4a-bdca-1c5218d739ce?source=cve
Get alerted when CVE-2025-14163 or the next vulnerability affects your stack