What’s Vulnerable › Vulnerabilities

CVE-2025-1437: Advanced iFrame <= 2025.2 - Authenticated (Contributor+) Stored Cross-Site Scripting

Description

The Advanced iFrame plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'advanced_iframe' shortcode in all versions up to, and including, 2025.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 2024.5, and later improved in version 2025.3.

Affected products

How to fix

Upgrade to a fixed version: mdempfle Advanced iFrame 2025.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1437 or the next vulnerability affects your stack