What’s Vulnerable › Vulnerabilities
CVE-2026-89288: Fast Courier 5.0.0 - 5.2.3 - Unauthenticated SQLi via 'wp_order_id' Parameter
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-89
Description
The Fast Courier WordPress plugin before 5.2.4 does not sanitize and escape a value before using it in a SQL query on an unauthenticated REST route, allowing unauthenticated attackers to perform SQL injection and read arbitrary data from the database.
Affected products
- Fast Courier: from 5.0.0 before 5.2.4 — fixed in 5.2.4
How to fix
Upgrade to a fixed version: Fast Courier 5.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-89288 or the next vulnerability affects your stack