What’s Vulnerable › Vulnerabilities
CVE-2021-24219: All Thrive Themes and Plugins - Unauthenticated Option Update
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-284
Description
The Thrive Optimize WordPress plugin before 1.4.13.3, Thrive Comments WordPress plugin before 1.4.15.3, Thrive Headline Optimizer WordPress plugin before 1.3.7.3, Thrive Leads WordPress plugin before 2.3.9.4, Thrive Ultimatum WordPress plugin before 2.3.9.4, Thrive Quiz Builder WordPress plugin before 2.3.9.4, Thrive Apprentice WordPress plugin before 2.3.9.4, Thrive Visual Editor WordPress plugin before 2.6.7.4, Thrive Dashboard WordPress plugin before 2.3.9.3, Thrive Ovation WordPress plugin before 2.4.5, Thrive Clever Widgets WordPress plugin before 1.57.1 and Rise by Thrive Themes WordPress theme before 2.0.0, Ignition by Thrive Themes WordPress theme before 2.0.0, Luxe by Thrive Themes WordPress theme before 2.0.0, FocusBlog by Thrive Themes WordPress theme before 2.0.0, Minus by Thrive Themes WordPress theme before 2.0.0, Squared by Thrive Themes WordPress theme before 2.0.0, Voice WordPress theme before 2.0.0, Performag by Thrive Themes WordPress theme before 2.0.0, Pressive by Thrive Themes WordPress theme before 2.0.0, Storied by Thrive Themes WordPress theme before 2.0.0, Thrive Themes Builder WordPress theme before 2.2.4 register a REST API endpoint associated with Zapier functionality. While this endpoint was intended to require an API key in order to access, it was possible to access it by supplying an empty api_key parameter in vulnerable versions if Zapier was not enabled. Attackers could use this endpoint to add arbitrary data to a predefined option in the wp_options table.
Affected products
- Thrivethemes Focusblog: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Ignition: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Luxe: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Minus: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Performag: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Pressive: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Rise: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Squared: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Storied: before 2.0.0 — fixed in 2.0.0
- Thrive Themes Thrive Apprentice: before 2.3.9.4 — fixed in 2.3.9.4
- Thrive Themes Thrive Clever Widgets: before 1.57.1 — fixed in 1.57.1
- Thrive Themes Thrive Comments: before 1.4.15.3 — fixed in 1.4.15.3
- Thrive Themes Thrive Dashboard: before 2.3.9.3 — fixed in 2.3.9.3
- Thrive Themes Thrive Headline Optimizer: before 1.3.7.3 — fixed in 1.3.7.3
- Thrive Themes Thrive Optimize: before 1.4.13.3 — fixed in 1.4.13.3
- Thrive Themes Thrive Ovation: before 2.4.5 — fixed in 2.4.5
- Thrive Themes Thrive Quiz Builder: before 2.3.9.4 — fixed in 2.3.9.4
- Thrive Themes Thrive Theme Builder: before 2.2.4 — fixed in 2.2.4
- Thrive Themes Thrive Visual Editor: before 2.6.7.4 — fixed in 2.6.7.4
- Thrive Themes Voice: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Thrivethemes Focusblog 2.0.0; Thrivethemes Ignition 2.0.0; Thrivethemes Luxe 2.0.0; Thrivethemes Minus 2.0.0; Thrivethemes Performag 2.0.0; Thrivethemes Pressive 2.0.0; Thrivethemes Rise 2.0.0; Thrivethemes Squared 2.0.0; Thrivethemes Storied 2.0.0; Thrive Themes Thrive Apprentice 2.3.9.4; Thrive Themes Thrive Clever Widgets 1.57.1; Thrive Themes Thrive Comments 1.4.15.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/35acd2d8-85fc-4af5-8f6c-224fa7d92900
- https://www.wordfence.com/blog/2021/03/recently-patched-vulnerability-in-thrive-themes-actively-exploited-in-the-wild
- https://wpscan.com/vulnerability/35acd2d8-85fc-4af5-8f6c-224fa7d92900
- https://www.wordfence.com/blog/2021/03/recently-patched-vulnerability-in-thrive-themes-actively-exploited-in-the-wild
Get alerted when CVE-2021-24219 or the next vulnerability affects your stack